The Chicago (CH1) facility has returned to utility power following the conclusion of the grid demand-response event. All services operated normally throughout. This incident is now resolved.
Posted Jul 03, 2026 - 13:09 BST
Update
The facility has completed the transfer to generator power and reports stable operation. All Clouvider services in Chicago remain unaffected. The site will stay on generator power pending the grid operator's all-clear.
Posted Jul 03, 2026 - 00:30 BST
Monitoring
Our upstream datacentre partner in Chicago (CH1) has transferred the facility from utility power to on-site generators at the request of the local grid operator, as part of a planned demand-response event during a period of high grid load. This is a controlled, proactive measure and is not the result of any fault.
All Clouvider services in Chicago are running normally. Power delivery to our infrastructure is protected by UPS and continues uninterrupted across the transfer; we do not anticipate any customer-visible impact. The facility holds a comfortable on-site fuel reserve and will remain on generator power until the grid operator confirms it is safe to return to utility supply.
We are monitoring the situation and will post further updates as we receive them, including confirmation once the site has transferred back to utility power.
Posted Jul 03, 2026 - 00:10 BST
This incident affected: Datacentres (CH1 - Chicago, IL).