Telehouse has provided a further update regarding the ongoing investigation into the Indirect Adiabatic Cooling (IAC) units serving TFM260 within Telehouse North 2.
Telehouse’s specialist cooling contractor has returned to site today to continue the investigation and optimisation activities. As part of these works, the internal bypass dampers within each IAC unit will continue to be inspected to verify that they are fully closed and operating correctly.
To facilitate these inspections, individual IAC units may be briefly taken out of service one at a time. These activities will continue to be carefully controlled and managed to ensure sufficient cooling capacity remains available throughout the investigation.
Environmental conditions within the data hall remain stable, and there continues to be no impact to customer services or the operating environment. The area remains under enhanced monitoring, and adjustments will be made where necessary to maintain appropriate environmental conditions.
We will provide a further update once today’s inspection activities have been completed, or sooner should there be any material change to the situation.
Posted Jun 25, 2026 - 16:28 BST
Update
fault has been identified with a component within IAC-06 serving TFM260. The IAC unit was momentarily shut down to allow the faulty component to be replaced. Telehouse has confirmed the faulty component has been successfully replaced and specialist engineers have verified the unit is back in operation.
At this time, cooling conditions within the area remain stable. The area continues to be closely monitored, with adjustments in place to maintain appropriate environmental conditions.
We will continue to provide updates should there be any material change to the situation.
Posted Jun 25, 2026 - 12:22 BST
Monitoring
Telehouse has provided a further update regarding the elevated temperatures within TFM260.
Environmental conditions within the data hall continue to remain stable, and customer services continue to operate normally. Telehouse’s engineering teams remain on heightened monitoring whilst external ambient air temperatures remain elevated.
Telehouse’s specialist cooling contractor has completed performance verification and optimisation checks on the Indirect Adiabatic Cooling (IAC) systems, and the effectiveness of the cooling infrastructure continues to be closely monitored. Operational adjustments will continue to be implemented where necessary to maintain appropriate environmental conditions.
At this time, there has been no impact to customer services or cooling resilience. We will continue to monitor environmental conditions closely and provide further updates should there be any material change to the situation.
Posted Jun 25, 2026 - 08:42 BST
Update
Telehouse has provided a further update regarding the elevated temperatures within TFM260.
Due to the current period of high external ambient air temperatures, elevated temperatures continue to be observed across the data hall. Environmental conditions remain under close observation and customer services continue to operate normally.
To ensure the cooling infrastructure is operating as efficiently as possible during this period of increased thermal demand, Telehouse’s specialist cooling vendor is currently onsite carrying out performance verification and optimisation checks on the Indirect Adiabatic Cooling (IAC) systems serving the area.
Telehouse’s engineering teams and specialist contractors continue to closely monitor environmental conditions and implement adjustments where necessary to maintain appropriate operating temperatures.
We will continue to provide updates should there be any material change to the situation.
Posted Jun 24, 2026 - 13:43 BST
Investigating
Our datacentre supplier, Telehouse, has advised that a gradual increase in temperatures has been observed in TFM260 over the past few hours, caused by significantly increased ambient temperatures.
Telehouse’s maintenance team is currently working to activate mitigation measures to bring temperatures back within expected operating ranges.
We are monitoring the situation closely and will provide further updates if there are any significant changes that require customer attention. We appreciate your patience while Telehouse works to stabilise the cooling environment.
Our core routing infrastructure at Telehouse is not currently affected but at risk as the temperatures continue to increase.
Our redundant core routing point for London metro is not currently affected.
Posted Jun 23, 2026 - 19:53 BST
This incident affected: Customer Portal (Customer Portal, Service Management API, OnApp Management Interface, Legacy Customer Portal), Datacentres (Docklands - London, UK), Hosted Services (Anycast DNS, Web Hosting, Public Cloud, Private Cloud, CDN, Dedicated Servers), Network (London, UK Core Network), and Main Website.